XenApp 7.x: When Accessing Anonymous/Unauthenticated Store, apps fail to enumerate. "There are no apps or desktops available for you.."

XenApp 7.x: When Accessing Anonymous/Unauthenticated Store, apps fail to enumerate. "There are no apps or desktops available for you.."

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Article ID: CTX233380

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Updated On:

Description

We generally get the blank screen without Apps and Desktops when accessing a store configured for anonymous access.
Storefront says: "There are no apps or desktops available to you at this time."

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Resolution

To fix this ensure that the following 3 settings are in place:

1) Option to ‘Give Access to unauthenticated users’ is selected by editing Delivery Group.
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2) On the Storefront, while creating the Store, ensure that the Unauthenticated option is checked.
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3) On Storefront Console, Click ‘Manage Delivery Controller’ -> Select each controller and Edit. Add transport type as HTTP.


If still the issue is not fixed feel free to Citrix Support Number for immediate assistance.

Problem Cause

Transport type set as HTTPS in Deliver Controller configuration on Storefront.