WEM Admin console fails to connect with error "Error while connecting to the specified Infrastructure Server!"

WEM Admin console fails to connect with error "Error while connecting to the specified Infrastructure Server!"

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Article ID: CTX233361

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Updated On:

Description

  • WEM admin console fails to connect with error "Error while connecting to the specified Infrastructure Server!"
User-added image
 
  • The Citrix WEM Console Trace.Log file located in the user profile (%username%) reports the following error:

"Exception -> ConnectToBroker.Run() : System.Net.Sockets.SocketException : No connection could be made because the target machine actively refused it."

Resolution

Check the Norskale Infrastructure Service in the Windows services console and to make sure it is running. If it is stopped, then start it. Then attempt to connect the WEM admin console again and monitor that the service does not stop again.
Configure the service Recovery to "Restart the Service" for the First, Second and Subsequent failures.
If the service is stopped again, we need to find out what is causing the service to stop.
 

Problem Cause

Norskale Infrasctructure Service was stopped. This probably was caused by a third party variable like an antivirus although it was not confirmed.
Make sure that the antivirus exclusions recommended for WEM are configured as per https://www.citrix.com/blogs/2016/12/02/citrix-recommended-antivirus-exclusions/ (search for Workspace Environment Management).