Printers assigned to users through WEM are not created in ICA, RDP and console sessions

Printers assigned to users through WEM are not created in ICA, RDP and console sessions

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Article ID: CTX232647

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Updated On:

Description

Printers assigned to users through WEM are not created in ICA, RDP and console sessions.

Resolution

To resolve this issue:

  1. Enable the "Automatic Self Healing" option for all the printers by editing each of them under Actions > Printers in the WEM admin console.

  2. Refresh the Agent Cache, Agent Host Settings and Workspace Agents by selection all agents and right clicking them under Administration > Agents.


Problem Cause

Self healing option was not enabled for the printers assigned through WEM. To optimize performance, WEM only applies an action once. The Self Healing option ensures to reapply the actions on every logon.

Additional Information

http://carlstalhood.com/workspace-environment-management/#createactions - Workspace Environment Management (WEM) 4.5 ("Create Actions" section)