book
Article ID: CTX232632
calendar_today
Updated On:
Description
Users can no longer install an application from the company store or get policies in XenMobile. When you try to install an app it goes from installing back to reinstall in Secure Hub and nothing is installed.
Resolution
Complete the following steps to resolve this issue:
- Locate the previous expired APNS cert on https://identity.apple.com/pushcert/ make sure this is the correct user and expired cert.
- Follow the process outlined in CTX200072 - How to Renew an APNS Certificate for XenMobile and make sure to renew the expired APNS cert.
- Upload the re-newed APNS cert to the XenMobile server and test.
Note that you update the certificate on the XenMobile console as soon as you have renewed it. If not, your iOS Device enrollment will be affected and in the Debug logs you will see an "invalid APNS certificate" error.
Problem Cause
When renewing the APNS cert a new APNS certificate was created, the existing APNS should have been renewed. As a result, new enrolment work, but all devices enrolled prior to the APNS cert cant connect or get apps.
Issue/Introduction
XenMobile iOS after importing an APNS cert app installation doesn't work