HTTP/2 Not Working When Profile is Bound
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Article ID: CTX232246
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Updated On:
Description
NetScaler vServer with HTTP profile bound.
The HTTP profile has HTTP/2 support enabled with standard options set:

Resolution
We changed the ciphers on the vServer and the NetScaler is now using HTTP/2
Problem Cause
NetScaler requires ECC ciphers when using HTTP/2
Previous ECC ciphers bound to vServer were not able to be used due to a number of reasons, such as:
type of Certificate used, SSL capability, etc.
Issue/Introduction
Customer configures HTTP profile, with HTTP/2 enabled from Client to vServer communication.
However, the NetScaler is not starting a HTTP/2 connection
Additional Information
https://docs.citrix.com/en-us/netscaler/12/system/http-configurations/configuring-http2.html
https://docs.citrix.com/en-us/netscaler/11/system/http-configurations/configuring-http2.html
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