Microsoft releases software updates for Windows 10 twice a year through the Semi-Annual Channel. On April 30, 2018, Microsoft released its latest Semi-Annual Channel release for Windows 10 called 'April 2018 Update' (v1803).
This article is intended to capture known issues with Windows 10 v1803 that have been identified so far through Citrix internal testing and customer reports.
Note:
Issue Description
The mouse cursor is distorted or may disappear at times when a published application or VDA is launched in full screen on multi-monitor setup with high DPI/Resolution.
[RFWIN-7040]
Problem Cause
Monochrome custom cursors created via CreateCursor() can be distorted on multi-monitor setups with mixed DPI in Windows 10.
Solution
Citrix is working with Microsoft to resolve this issue. As a workaround, the user may manually add the registry key manually and then uninstall Citrix Desktop Lock by following below steps:
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry
Right click on Start button and choose Run
Type ‘Regedit’ and click Ok.
On x86 machine, browse to HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon
On x64 machine, browse to HKEY_LOCAL_MACHINE -> Software -> WOW6432Node -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon
Right click on Winlogon in left pane, choose New -> String Value
Enter the value as ‘CtxBackUpShell ’ and hit enter.
Double click on ‘CtxBackUpShell ’ and enter the value as ‘explorer.exe’.
Close Registry Editor and uninstall Desktop Lock.
Issue Description
Pin prompt for Smart card authentication is not available to login into VDA session. User is prompted for “Username” and “Password” instead of Smart card PIN to login into VDA session.
[HDX-13195]
Problem Cause
Microsoft has changed the way Smart Card Service (SCardSvr) works in Windows 10 v1803. The service will run only if a Smart Card reader is connected. As ICA sessions redirect the Smart Card, it finds the service not to be running and fails.
Solution
This issue would not be encountered if earlier Windows 10 machine with VDA installed is upgraded to 1803. For a clean install of Windows 10 v1803, Microsoft has provided a mechanism to enable to enable Smart Card Service (SCardSvr) by adding a registry key. To add the registry key, follow below steps on the VDA:
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry
Right click on Start button and choose Run
Type ‘Regedit’ and click Ok.
On x86 machine, browse to HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Cryptography -> Calais
On x64 machine, browse to HKEY_LOCAL_MACHINE -> Software -> WOW6432Node -> Microsoft -> Cryptography -> Calais
Right click on Calais in left pane, choose New -> DWORD (32 bit) value.
Enter the value as ‘AllowServiceAccessWithNoReaders’ and hit enter.
Double click on ‘AllowServiceAccessWithNoReaders’ and enter the value as 1.
Close Registry Editor and restart the machine.
Issue Description
Print command from inside an ICA session of Windows 10 v1803 client fails to print using mapped Citrix UPS configured XPS Printer.
[HDX-13664]
Problem Cause
XPS Viewer is not available on Windows 10 v1803 by default. It is available as a Feature on Demand.
Solution
To install XPS Viewer, follow the below steps:
Note:
Issue Description
Citrix Workspace Environment Management (WEM) Agent fails to work when Windows 10 is upgraded to v1803.
[TPV-1184]
Problem Cause
The ‘Norskale’ key under [HKLM -> System -> CurrentControlSet -> Control] is removed during the upgrade to v1803.
Solution
Citrix is working with Microsoft to resolve this issue. To restore functionality, users could uninstall WEM Agent on the upgraded machine, reinstall and reconfigure.
Issue Description
Some maximized applications in Local App Access(LAA) enabled desktop sessions cannot be minimized using the minimize button. (Example application: Notepad, CMD)
[LC8813]
Problem Cause
The issue is due to an incorrect function call getting triggered for LAA enabled desktops.
Solution
This issue is resolved in Citrix XenDesktop 7.18 and CU2 for XenDesktop 7.15.
Issue Description
Citrix User Profile Manager (UPM) stops working after Windows 10 is upgraded to v1803.
[TPV-1307]
Problem Cause
The upgrade process is removing some of the registry entries related to UPM.
Solution
This issue is fixed with the Microsoft's March 2019 Updates for Windows 10. Install the respective March 2019 update OR its replacement on your existing Windows 10 version before upgrading to Windows 10 v1803.
Issue Description
With Windows 10 v1803 as PVS Target Device (PVS 7.15 CU2), when Cache Type for vDisk is set as ‘Cache in device RAM’, a BSOD is encountered while booting.
[PVS-3634]
Problem Cause
This issue could be due to Kernel changes made in Windows 10 v1803 which might be preventing the Citrix PVS bootstrap and drivers from using reserved memory for RAM cache.
Solution
Citrix is investigating this issue. As a workaround, “Cache in device RAM with overflow on hard disk” option can be used.
Note: Windows server 2019 has the same issue. This only affects Legacy bootstrap PXE booting, which includes BDM and ISO booting. Using UEFI bootstrap works fine, including UEFI BDM and ISO booting.
Issue Description
Virtual Smart Card Reader (created by tpmvscmgr.exe) stops functioning after Windows 10 is upgraded from v1709 to v1803 with Citrix VDA installed.
Problem Cause
The Windows Upgrade process is rendering the Virtual Smart Card Reader non-functional. This issue is not encountered with a fresh install of Windows 10 v1803
Solution
Citrix is investigating this issue. As a workaround, users could login to the VDA using user name and password, go to the Device Manager and disable the Virtual Smart Card Reader and enable it again. This can also be done programmatically via Powershell with the following:
From a PoSH session run “Get-PnpDevice | ft FriendlyName,InstanceID”
In the Output match the friendly name with the name in device manager and also the one given when it was created with tpmvscmgr.exe. The InstanceID should look something like ROOT\SMARTCARDREADER\0000
Once the InstanceID is identified the cmdlets to enable\disable the device are relatively simple:
Disable-pnpDevice –InstanceID ROOT\SMARTCARDREADER\0000 –Confirm:$false
Enable-pnpDevice –InstanceID ROOT\SMARTCARDREADER\0000 –Confirm:$false
Running a script with these cmdlets restores the Virtual Smartcard to a working state and could be incorporated into a startup\logon script.
References:
https://docs.microsoft.com/en-us/powershell/module/pnpdevice/get-pnpdevice?view=win10-ps
https://docs.microsoft.com/en-us/powershell/module/pnpdevice/disable-pnpdevice?view=win10-ps
https://docs.microsoft.com/en-us/powershell/module/pnpdevice/enable-pnpdevice?view=win10-ps
Issue 12
Issue Description
Pass-Through Authentication (SSON) fails to work when Windows 10 is upgraded to v1803 with Workspace App installed.
[TPV-1916]
Problem Cause
While upgrading to v1803, few registry entries required by SSON gets removed under HKLM > System > CurrentControlSet > Control > NetworkProvider.
Solution
Users may manually add the registry keys (Workaround 1) OR run a Power Shell script (Workaround 2) that adds the registry entries that were deleted by the installer.
Workaround 1:
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry
Right click on Start button and choose Run
Type regedit and click OK.
Browse to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services.
Right-click on Services and choose New > Key.
Enter value PnSson for the new key and click OK.
Right-click the key PnSson for and choose New > DWORD 32 bit, enter IsEnabled and set Value data 1
Right-click the key PnSson for and choose New > DWORD 32 bit, enter Type and set Value data 4
After adding the keys and values, it should appear like below:
Right-click NetworkProvider > New > String Value, enter Name and set Value data Citrix Single Sign-on.
Right-click NetworkProvider > New > String Value, enter ProviderPath and set Value data to below value:
C:\Program Files (x86)\Citrix\ICA Client\x64\pnsson.dll on 64 bit Machine
C:\Program Files\Citrix\ICA Client\pnsson.dll on 32 bit Machine
Note: If Workspace App is installed in Custom location, the above values should be changed accordingly to $InstallPath$\ICA Client\... Example: If install path is c:\Citrix then the value should be C:\Citrix\ICA Client\....
Right-click NetworkProvider > New > DWORD 32 bit, enter Class and set Value data 2.
After adding the keys and values, it should appear like below:
Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> Order
Right Click on ProviderOrder and Select Modify.
Add ,Pnsson to the end of the current value in the registry.
After adding the keys and values, it should appear like below:
Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> HwOrder
Right Click on ProviderOrder and Select Modify.
Add ,Pnsson to the end of the current value in the registry.
After adding the keys and values, it should appear like below: