Windows 10 April 2018 Update (v1803) – Citrix Known Issues

Windows 10 April 2018 Update (v1803) – Citrix Known Issues

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Article ID: CTX231942

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Updated On:

Description

Microsoft releases software updates for Windows 10 twice a year through the Semi-Annual Channel. On April 30, 2018, Microsoft released its latest Semi-Annual Channel  release for Windows 10 called 'April 2018 Update' (v1803). 

This article is intended to capture known issues with Windows 10 v1803 that have been identified so far through Citrix internal testing and customer reports.

  • Citrix Virtual Delivery Agent (VDA) for Windows Desktop OS
  • Citrix Receiver for Windows
  • Citrix Provisioning Services (PVS)
  • Citrix Workspace Environment Management (WEM)
  • Citrix User Profile Management (UPM)


Note:

  • This is a live article and is updated as and when new information is available.
  • Citrix supports XenApp/XenDesktop, PVS version 7.18 or 7.15 CU2 to use with Windows 10 v1803.

Known Issues

The following are the known issues:

Issue 1

Issue Description
When a user tries to launch a published desktop in full-screen mode using Smart card authentication through a NetScaler environment, the PIN prompt is not visible and just the progress indicator is seen. The connection times out and the launching desktop process closes.
[LC8579]
 
Problem Cause
Full-screen sessions hide the PIN prompt window. The Windows Security and UAC prompt are updated from Winform to XAML. This causes the PIN prompt window to lose focus and stay in the background.

Solution
This is a known issue with Citrix Receiver (https://docs.citrix.com/en-us/receiver/windows/current-release/about/known-issues.html). 
  • Users on Current Release of Citrix Receiver are advised to upgrade to Citrix Receiver 4.12 or its replacement that contains the fix.
  • Users on the LTSR version(version 4.9) of Receiver are advised to upgrade to Citrix Receiver 4.9.3000 or its replacement that contains the fix.


Issue 2

Issue Description
The mouse cursor could appear smaller within a session when using display with high DPI/Resolution
[HDX-9959]

Problem Cause
Monochrome custom cursors created via CreateCursor() in a non-DPI aware application do not scale correctly with Windows 10 v1703 and later versions. Custom cursors created via CreateInconIndirect() in a non-DPI aware application do not scale correctly in all versions of Windows 10.

Solution
  • Users on Current Release of Citrix Receiver (version 4.8) are advised to upgrade to Citrix Receiver 4.11 or its replacement that avoids the cursor scaling issue.
  • Users on the LTSR version(version 4.9) of Receiver are advised to upgrade to Citrix Receiver 4.9.3000 or its replacement that avoids the cursor scaling issue.


Issue 3

Issue Description

The mouse cursor is distorted or may disappear at times when a published application or VDA is launched in full screen on multi-monitor setup with high DPI/Resolution.
[RFWIN-7040]

Problem Cause
Monochrome custom cursors created via CreateCursor() can be distorted on multi-monitor setups with mixed DPI in Windows 10.

Solution

  • Users on Current Release of Citrix Receiver (version 4.8) are advised to upgrade to Citrix Receiver 4.11 or its replacement that avoids the cursor scaling issue.
  • Users on the LTSR version(version 4.9) of Receiver are advised to upgrade to Citrix Receiver 4.9.3000 or its replacement that avoids the cursor scaling issue.


Issue 4

Issue Description
Users are unable to uninstall Desktop Lock if Windows 10 was upgraded to v1803 with Desktop Lock installed.
[TPV-744]

Problem Cause
During the upgrade,the key CtxBackupShell is getting removed under [HKLM -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon] . As a result, an error message "1: Read failed HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\CtxBackupShell=(32bit on 32bit)" is displayed.

Solution

Citrix is working with Microsoft to resolve this issue. As a workaround, the user may manually add the registry key manually and then uninstall Citrix Desktop Lock by following below steps:

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

  1. Right click on Start button and choose Run

  2. Type ‘Regedit’ and click Ok.

    On x86 machine, browse to HKEY_LOCAL_MACHINE  -> Software -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon
    On x64 machine, browse to HKEY_LOCAL_MACHINE  -> Software -> WOW6432Node -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon

  3. Right click on Winlogon in left pane, choose New -> String Value

  4. Enter the value as ‘CtxBackUpShell ’ and hit enter.

  5. Double click on ‘CtxBackUpShell ’ and enter the value as ‘explorer.exe’.

  6. Close Registry Editor and uninstall Desktop Lock.
     


Issue 5

Issue Description

Pin prompt for Smart card authentication is not available to login into VDA session. User is prompted for “Username” and “Password” instead of Smart card PIN to login into VDA session.
[HDX-13195]

Problem Cause 

 Microsoft has changed the way Smart Card Service (SCardSvr) works in Windows 10 v1803. The service will run only if a Smart Card reader is connected. As ICA sessions redirect the Smart Card, it finds the service not to be running and fails.

Solution

This issue would not be encountered if earlier Windows 10 machine with VDA installed is upgraded to 1803. For a clean install of Windows 10 v1803, Microsoft has provided a mechanism to enable to enable Smart Card Service (SCardSvr) by adding a registry key. To add the registry key, follow below steps on the VDA:

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

  1. Right click on Start button and choose Run

  2. Type ‘Regedit’ and click Ok.

    On x86 machine, browse to HKEY_LOCAL_MACHINE  -> Software -> Microsoft -> Cryptography -> Calais
    On x64 machine, browse to HKEY_LOCAL_MACHINE  -> Software -> WOW6432Node -> Microsoft -> Cryptography -> Calais

  3. Right click on Calais in left pane, choose New -> DWORD (32 bit) value.

  4. Enter the value as ‘AllowServiceAccessWithNoReaders’ and hit enter.

  5. Double click on ‘AllowServiceAccessWithNoReaders’ and enter the value as 1.

  6. Close Registry Editor and restart the machine.

Issue 6

Issue Description

Print command from inside an ICA session of Windows 10 v1803 client fails to print using mapped Citrix UPS configured XPS Printer.
[HDX-13664]

Problem Cause

XPS Viewer is not available on Windows 10 v1803 by default. It is available as a Feature on Demand.

Solution

To install XPS Viewer, follow the below steps:

  • Open Command Prompt in elevated mode
  • Run the command “Dism /online /add-capability /CapabilityName:XPS.Viewer~~~~0.0.1.0”

Note:

  • The machine should be connected to the Internet for above command to acquire and install XPS Viewer.
  • While upgrading from earlier Windows 10 version to v1803 using ISO, if option 'Download and install updates' is chosen XPS Viewer will be retained after upgrade.

Issue 7

Issue Description

Citrix Workspace Environment Management (WEM) Agent fails to work when Windows 10 is upgraded to v1803.
[TPV-1184]

Problem Cause

The ‘Norskale’ key under [HKLM -> System -> CurrentControlSet -> Control] is removed during the upgrade to v1803.

Solution

Citrix is working with Microsoft to resolve this issue. To restore functionality, users could uninstall WEM Agent on the upgraded machine, reinstall and reconfigure.

 

Issue 8

Issue Description

Some maximized applications in Local App Access(LAA) enabled desktop sessions cannot be minimized using the minimize button. (Example application: Notepad, CMD)
[LC8813]

Problem Cause

The issue is due to an incorrect function call getting triggered for LAA enabled desktops.

Solution

This issue is resolved in Citrix XenDesktop 7.18 and CU2 for XenDesktop 7.15.


Issue 9

Issue Description

Citrix User Profile Manager (UPM) stops working after Windows 10 is upgraded to v1803.
[TPV-1307]

Problem Cause

The upgrade process is removing some of the registry entries related to UPM.

Solution

This issue is fixed with the Microsoft's March 2019 Updates for Windows 10. Install the respective March 2019 update OR its replacement on your existing Windows 10 version before upgrading to Windows 10 v1803.

Issue 10

Issue Description

With Windows 10 v1803 as PVS Target Device (PVS 7.15 CU2), when Cache Type for vDisk is set as ‘Cache in device RAM’, a BSOD is encountered while booting.
[PVS-3634]

Problem Cause

This issue could be due to Kernel changes made in Windows 10 v1803 which might be preventing the Citrix PVS bootstrap and drivers from using reserved memory for RAM cache.

Solution

Citrix is investigating this issue. As a workaround, “Cache in device RAM with overflow on hard disk” option can be used.

Note: Windows server 2019 has the same issue. This only affects Legacy bootstrap PXE booting, which includes BDM and ISO booting. Using UEFI bootstrap works fine, including UEFI BDM and ISO booting.
 

Issue 11

Issue Description

Virtual Smart Card Reader (created by tpmvscmgr.exe) stops functioning after Windows 10 is upgraded from v1709 to v1803 with Citrix VDA installed.

Problem Cause

The Windows Upgrade process is rendering the Virtual Smart Card Reader non-functional. This issue is not encountered with a fresh install of Windows 10 v1803

Solution

Citrix is investigating this issue. As a workaround, users could login to the VDA using user name and password, go to the Device Manager and disable the Virtual Smart Card Reader and enable it again.  This can also be done programmatically via Powershell with the following:

From a PoSH session run “Get-PnpDevice | ft FriendlyName,InstanceID”

In the Output match the friendly name with the name in device manager and also the one given when it was created with tpmvscmgr.exe. The InstanceID should look something like ROOT\SMARTCARDREADER\0000   

Once the InstanceID is identified the cmdlets to enable\disable the device are relatively simple:
 
Disable-pnpDevice –InstanceID ROOT\SMARTCARDREADER\0000 –Confirm:$false
Enable-pnpDevice –InstanceID ROOT\SMARTCARDREADER\0000 –Confirm:$false
 
Running a script with these cmdlets restores the Virtual Smartcard to a working state and could be incorporated into a startup\logon script.

References:
 
https://docs.microsoft.com/en-us/powershell/module/pnpdevice/get-pnpdevice?view=win10-ps
 
https://docs.microsoft.com/en-us/powershell/module/pnpdevice/disable-pnpdevice?view=win10-ps
 
https://docs.microsoft.com/en-us/powershell/module/pnpdevice/enable-pnpdevice?view=win10-ps


Issue 12

Issue Description

Pass-Through Authentication (SSON) fails to work when Windows 10 is upgraded to v1803 with Workspace App installed. 
[TPV-1916]

Problem Cause

While upgrading to v1803, few registry entries required by SSON gets removed under HKLM > System > CurrentControlSet > Control > NetworkProvider.

Solution

Users may manually add the registry keys (Workaround 1) OR run a Power Shell script (Workaround 2) that adds the registry entries that were deleted by the installer.

Workaround 1:
Caution
! Refer to the Disclaimer at the end of this article before making changes to Registry

  1. Right click on Start button and choose Run

  2. Type regedit and click OK.

  3. Browse to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services.

  4. Right-click on Services and choose New > Key.

  5. Enter value PnSson for the new key and click OK.

  6. Right-click the key PnSson for and choose New > DWORD 32 bit, enter IsEnabled and set Value data 1

  7. Right-click the key PnSson for and choose New > DWORD 32 bit, enter Type and set Value data 4

  8. After adding the keys and values, it should appear like below:

    User-added image
  9. Right-click the key PnSson and choose New > Key.
  10. Enter value NetworkProvider and click OK.
  11. Add the following entries under the newly created key:
    • Right-click NetworkProvider > New > String Value, enter Name and set Value data Citrix Single Sign-on.

    • Right-click NetworkProvider > New > String Value, enter ProviderPath and set Value data to below value:

      C:\Program Files (x86)\Citrix\ICA Client\x64\pnsson.dll on 64 bit Machine

      C:\Program Files\Citrix\ICA Client\pnsson.dll on 32 bit Machine

      Note: If Workspace App is installed in Custom location, the above values should be changed accordingly to $InstallPath$\ICA Client\... Example: If install path is c:\Citrix then the value should be C:\Citrix\ICA Client\....

    • Right-click NetworkProvider > New > DWORD 32 bit, enter Class and set Value data 2.

  12. After adding the keys and values, it should appear like below:

    User-added image
  13. Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> Order

  14. Right Click on ProviderOrder and Select Modify.

  15. Add ,Pnsson to the end of the current value in the registry.

  16. After adding the keys and values, it should appear like below:

    User-added image
  17. Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> HwOrder

  18. Right Click on ProviderOrder and Select Modify.

  19. Add ,Pnsson to the end of the current value in the registry.

  20. After adding the keys and values, it should appear like below:

    User-added image
  21. Restart the machine.
Workaround 2:
Users could run the Power Shell script that adds the above entries. Download the attachment.zip file, extract it to a folder and run Receiver_SSON.PS1. This script will add the registry entries based on the Receiver install location. It also retains services registered with Microsoft Network Provider and appends PnSson value. Users are advised to test the script before using it in a production environment.


 

 

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Issue/Introduction

Microsoft releases regular builds of the next version of Windows 10 through their Insider Preview Program. Citrix does not support Insider Preview builds as stated on CTX224843 – Windows 10 Compatibility with Citrix XenDesktop.