Error: "HTTP/1.1 Internal Server Error 43554" When Logging to NetScaler

Error: "HTTP/1.1 Internal Server Error 43554" When Logging to NetScaler

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Article ID: CTX231850

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Description

App Enumeration failure with "HTTP 1.1 Internal server error 43554"

Resolution

This mostly happens due to incorrect configuration of Session Profile. 

You should make sure,
  • Store address is correct in wi address.
  • Try to resolve the SF FQDN on NetScaler.
  • If SF FQDN DNS is the issue,  then to validate, use IP of SF/ WI instead of domain name.
  • Sometimes, this occurs because of "https://support.citrix.com/article/CTX216509"

Problem Cause

>> NetScaler Gateway vserver is configured, while getting error "http:// internal service error"

>> Verified the configuration on NetScaler the address in published application was not correct. Correct the address.
Web Browsers -->Web Interface Address: https:<Ip or FQDN of SF Server>/citrix/<StoreName> Receiver: Web Interface Address: https:<Ip or FQDN of SF Server> 

>> Also check the policy hit command the session profile policy is also getting hit.
nsconmsg -d current -g pol_hits

>> Created the new test gateway server on the storefront server.

>>Storefront address was incorrect in Session profile.
You can traverse to Session Profile by following this path,
NetScaler Gateway > Virtual Servers > Edit virtual server > Session Policies > Select Session Policy and Click Edit Session Profile > Published Applications > Web Interface Address > Edit the address to the correct one.

Example Configuration,
User-added image

Additional Information

https://support.citrix.com/article/CTX138840
https://support.citrix.com/article/CTX139963