User getting App Layering error at logon- "This system was not shutdown properly"

User getting App Layering error at logon- "This system was not shutdown properly"

book

Article ID: CTX231631

calendar_today

Updated On:

Description

When a domain user logs on to an image that has been published by App Layering and the image has User Layers enabled, they may receive an error. 

User-added image

 

Resolution

Solution 1

Reboot the machine, the machine may not have been rebooted and therefore may not have reverted.  

Solution 2

After publishing an image via App Layering, never logon as a domain user while the image is persistent.  If you do, you will need to revert to a previous snapshot or republish the image.  You can only logon as a local user if the published image persistent.  You should also be able to run processes with different credentials but you cannot actually logon as any domain user if the image is configured to use user layers. 

Solution 3

If using a Dedicated pool in View, create a new Float pool so the machines are non-persistent. 

Problem Cause

This issue can be caused if the machine was not properly reverted when it was rebooted.  It can also be caused if the image was put in a persistent mode such as editing a master image or putting a PVS image in private mode and then logging on as any domain user.  If you logon as any domain user while the image is persistent  and then deploy that image, the user layer service will think the disk has not been properly reverted.

In the case of Horizon View, the pool must bet floating, not dedicated.  The machines must be non-persistent.