Error : "An error occurred while building your environment...". Synchronization State of WEM Agents Has a Red "X"

Error : "An error occurred while building your environment...". Synchronization State of WEM Agents Has a Red "X"

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Article ID: CTX231630

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Updated On:

Description

  • After upgrading WEM from 4.2 to 4.4, WEM agents are failing to connect to the WEM server with the following error:
"An error occurred while building your environment. Agent processing will now stop. Please contact your Administrator."
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  • Issue only occurs when connections are going through Load Balancer (NetScaler VIP) to second WEM server.
  • Synchronization State of WEM agents is shown with a red X on the WEM admin console under Administration > Agents > Statistics.
  • Norskale Broker Service events report database connectivity issues from the WEM server affected":
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Resolution

  1. Ensure the "WEM Infrastructure Service Configuration" console has the required configurations on all the WEM servers.
  2. Under "Database Settings" tab configure the following settings:
    • Database server and instance name.
    • Database name.
  3. Under "Advanced Settings" tab configure the following setting:
    Enable Windows account impersonation (and enter the WEM service account).
  4. Save the settings with the "Save Configuration" button which will restart the Norskale Infrastructure Service.
  5. Test again.

Problem Cause

After upgrading WEM from 4.2 to 4.4, for some unknown reason, all the configurations made on the "WEM Infrastructure Service Configuration" console were wiped out on one of the WEM servers ("Database Settings" and "Advanced Settings" tabs). Due to this, the Event Viewer on the WEM server in question was reporting database connectivity issues and this was causing the Agents to fail to connect to that WEM server. 

All the default settings should be in place after the upgrade.