Director showing error "Network unreachable. Check configuration, authentication, or service availability"

Director showing error "Network unreachable. Check configuration, authentication, or service availability"

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Article ID: CTX231463

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Updated On:

Description

While connecting to Citrix ADM(MAS) from Director customer is getting error "Network unreachable. Check configuration, authentication, or service availability. "
For configuring the Director with Citrix ADM(MAS) follow the blog: https://www.citrix.com/blogs/2016/10/12/configure-director-with-netscaler-management-analytics-system-mas/

But after that user is unable to view Network details in Director's network view with error shown as "Network unreachable. Check configuration, authentication, or service availability."
 

Resolution

The issue could be fixed by following one of the options.
  • Check the HTTPS connectivity between Citrix AMD(MAS) and Director trust the Citrix ADM(MAS) certificate in Director. If you are using a self-signed cert, the server that you created the cert on is the root cert. This cert should also be placed inside the trusted root cert store of your computer. To add the certificate to the trusted root on Director, please follow below process: go to MMC > Add/Remove snap-in > Certificates > Computer > Local > Trusted Root Certification Authorities > install the root certificate.
  • check if "Secure access only" is checked under Citrix ADM(MAS) System--> System configuration.You may uncheck the same and can configure the Citrix ADM(MAS) to allow HTTP connection if don't want to trust the certificate and want to continue the connection using HTTP.  Please note that if you uncheck the Secure access only the Director to ADM(MAS) connectivity will be established over HTTP and not HTTPS.
 

Problem Cause

HTTPS connection may not get establish between Citrix ADM(MAS) and director due one of the below reasons.
  • SSL certificates for Citrix ADM(MAS) are not trusted in app director.

Issue/Introduction

While connecting to Citrix ADM(MAS) from Director customer is getting error "Network unreachable. Check configuration, authentication, or service availability.  "