The Citrix Monitor service was unable to access its historical database

The Citrix Monitor service was unable to access its historical database

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Article ID: CTX231026

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Updated On:

Description

Health Check has detected that the Citrix Monitor service was unable to access its historical database. Could be caused by an issue with the Monitor database, it's connection string or a network issue, or permissions issue on the database. 

Resolution

Perform the following tasks to repair the monitor service:

1. Ensure the permissions on the database is configured correctly as outlined in  Database Access and Permission Model for XenDesktop
2. On the Delivery Controller, open a PowerShell command window in elevated mode
3. Load the Citrix snapins by typing 'Add-PsSnapin Citrix*'
4. Ensure that the connection string is configured correctly, and that the database server is healthy and up and running by typing 
  • Get-MonitorDBConnection -DataStore Monitor 
5. Test the DB connectivity  by running the Test-MonitorDBConnection command
  • E.g Test-MonitorDBConnection –dbconnection “<connection string>”
6. If the connection string is incorrect, null the connection, set the connection. For examples, see Get-Help Set-MonitorDBConnection

7. Restart the service Citrix Monitor service On the Delivery Controller, by launching the Services console: Click **Start** and then type **Services**.
8.    From the Services console, right-click **Citrix Monitor Service** and select **Restart**.
9.    Check the Event Log for any errors. 
 

Problem Cause

Database access was denied for Citrix Monitor Service