Web Insight Data Not Visible on NetScaler MAS

Web Insight Data Not Visible on NetScaler MAS

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Article ID: CTX230884

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Updated On:

Description

AppFlow (aka Insight) has been enabled for the VServer and Services. Enabled Web Insights on NetScaler MAS no data is displayed.

Firewall port UDP 4739 is allowed from the NetScaler NSIP/SNIP to the MAS appliance.

ULFD was disabled and server was removed.

Resolution

This is due to a known issue. As the removing of ULFD is not clean in older versions we need to reboot the NetScaler after disabling and removing the ULFD server.


Problem Cause

Known issue as the ULFD config doesn't clean up even after removing from the configuration and NetScaler has to be rebooted to get the Web Insight data flowing out of NetScaler for MAS

Only if the ULFD mode/server has been removed/disabled anytime during configuration/testing, we need to restart NetScaler for the Web Insight data to be presented on MAS 11.1.50.x onwards and 12.0.14.x onwards

Issue/Introduction

AppFlow (aka Insight) has been enabled for the VServer and Services. Enabled Web Insights on NetScaler MAS no data is displayed.

Additional Information

Citrix Documentation - Web Insight

Citrix ADM version 12.1 build 49.37 and above has self-service diagnostics for Analytics which is used to identify the license and configuration issues on the managed instances which could lead to no data being captured. The self-service diagnostics helps you to identify and troubleshoot the issues faster. For more information refer to Citrix Documentation - Self-service diagnostics for Analytics.