Error: "Your logon has expired. Please log on again to continue" When one XML broker does not work correctly, users are unable to see apps and desktops from other working XML brokers.

Error: "Your logon has expired. Please log on again to continue" When one XML broker does not work correctly, users are unable to see apps and desktops from other working XML brokers.

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Article ID: CTX230777

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Updated On:

Description

When one XML broker does not work correctly, users are unable to see apps and desktops from other working XML brokers if StoreFront . The following error is displayed.
"Your logon has expired. Please log on again to continue."

This problem happens if the store has been configured with multiple delivery controllers that join domains that have no trust between.

This problem was fixed by LC6928 on StoreFront 3.11 and 3.0.4000. But it happens on StoreFront 3.12 or later.

Resolution

Please configure trust between all domains that have XenApp/XenDesktop site.

Problem Cause

It's an unsupported scenario to put together sites from different domains into a single store, if the domains have no trust between.