Error "XDDS:9984398A" on mandatory Site upgrade

Error "XDDS:9984398A" on mandatory Site upgrade

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Article ID: CTX230381

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Updated On:

Description

Mandatory Site upgrade on first DDC fails with error "XDDS:9984398A".

Exception:
    Citrix.Console.Common.CitrixAggregateException One or more parallel operations failed
       at Citrix.Console.Common.CitrixParallel.InternalForEach[TIn](IEnumerable`1 items, Action`1 operation, Int32 maxSimultaneous)
       at Citrix.Console.PowerShellSdk.SiteInformationService.SiteInformationService.Refresh()
       at Citrix.Console.DeliveryCenter.UI.ViewModel.DesktopStudioViewModel.LoadSiteState(IProgressReporter progressReporter)
       at Citrix.Console.Common.OperationTimer.TimeBlock(Action operation)
       at Citrix.Console.CommonControls.ProgressDisplay.GenericProgressOperationWithFeedBack.PerformOperationInternal()
       at Citrix.Console.CommonControls.ProgressDisplay.ProgressWindowOperation.PerformOperation()
       at Citrix.Console.CommonControls.ProgressDisplay.ProgressWindowViewModel.PerformAction(Action operationComplete)
   
    
Inner Exception:
    Citrix.Console.Models.Exceptions.ScriptException An unexpected error occurred.
       at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host)
       at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover)
       at Citrix.Console.PowerShellSdk.LicensingService.Scripts.GetLicenseInformationScript.RunScript()
       at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()
       at Citrix.Console.PowerShellSdk.SiteInformationService.SiteInformationService.GetLicenseAlert()
       at Citrix.Console.PowerShellSdk.SiteInformationService.SiteInformationService.<>c__DisplayClass33_0.<Refresh>b__7()
       at Citrix.Console.Common.CitrixParallel.<>c__DisplayClass4_1`1.<InternalForEach>b__0(Object arg)
 

Resolution

As a workaround follow below steps:
-> Stop Citrix Telemetry service on all the Controllers
-> Proceed with performing upgrade of remaining controllers.
-> Once upgrade is completed on all the controllers studio should work fine without any issues.
-> Start Citrix Telemetry Service on all the controllers.

Problem Cause

Citrix Telemetry Service was causing issues while executing GetLicenseInformationScript on remote controllers as part of post upgrade checks.

Additional Information

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/whats-new/known-issues.html