Error shown on the WEM Agents: "An error occurred while building your environment. Agent processing will now stop."
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Article ID: CTX229837
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Updated On:
Description
- Following error is shown on the right lower corner of the screen on the WEM Agents every time the VUEMUIAgent is launched or refreshed:
- Event Viewer on the WEM Agents reports the following error under Norskale Agent Service when the issue occurs:
- The "WEM Agent Session Log" shows the following exception every time the issue occurs:
Event -> AgentControllersHelper.CheckDomainType() : Checking Domain Type…
Event -> AgentControllersHelper.CheckDomainType() : RetrievingDomainType() Result -> Active Directory
Event -> MainController.StartUserGroupsRetrievalASync() : Starting User Groups Extraction…
Event -> VuemAgentConfigurationHelper.RetrieveConfiguredUsers() : Retrieving WEM Users…
Exception -> MainController.InternalRun() : No user Group found … Exiting.
Resolution
- Increase the "Directory Services Timeout" value from 2000 ms to 20000 ms on the WEM Admin console under Advanced Settings > Agent Options > Extra Features.
- Make sure to Apply the Setting.
- Go to Administration > Agents and do right click on the Agent and run the first three options shown in the menu:
- Refresh Cache...
- Refresh Agent Host Settings...
- Refresh Workspace Agent(s)...
- Go to the WEM Agent and logoff and then log back in to test.
Problem Cause
WEM Agent times out while connecting to Active Directory to retrieve the User Groups.
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