How to Re-Enable Camera when it is Blocked by Restriction policy
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Article ID: CTX229783
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Description
How to Remove Restriction Policy from the iOS Devices without Re-enrolling.
For Eg:- Customer has pushed the camera restriction policy to the Delivery Group to block the camera access for the users and now want to remove the unblock the camera to their end users by moving into other delivery group which does not contains camera restriction policy.
Resolution
You need to use Profile Removal Policy instead of making changes in the already existing Restriction Policy.
The current restriction is still on the device so creating another with camera enable option will not help because of below reason.
- The user "test" got restriction profile with "Camera disable" installed when he belongs to 'abcd' DG. Let me say: "Camera disable" = TRUE in this profile1.
- When he was switched to 'xyze' DG, and 'xyze' DG has a profile2 whose "Camera disable" = FALSE (camera is enabled).
- The final value for this "Camera disable" is: ("Camera disable" in profile1) | ("Camera disable" in profile2) = TRUE.
In order to enable camera after a "Camera disable" restriction policy deployment, you need to use Profile Removal Policy.
- Create "Profile Removal" policy and select the camera disable restriction profile and deploy to the ‘xyze’ delivery group to remove the camera disable restriction profile from the device.
- Move the ‘test’ user from ‘abc’ AD group to ‘xyz’ AD group.
- Refresh the policy or click on deploy selecting the user. you will be able to see Camera now since the restriction profile is removed now.
Problem Cause
Restriction Policy is still on the Device and unless it is not removed from the device Camera will remain blocked.
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