Citrix Receiver keeps prompting for authentication when accessed remotely
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Article ID: CTX229464
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Updated On:
Description
Getting prompted by the Citrix Receiver client to authenticate and to enter user name and password. It does not happen when the laptop is connected to the internal network. Only happens over VPN.
Resolution
Put in the following registry keys:
a) HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Dazzle: Set
InitialRefreshMaxMs, InitialRefreshMinMs and RefreshMs to REG_SZ Value 0;
b) Add HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Dazzle: Set
SelfServiceFlags to REG_DWORD Value 0x1.
c) HKEY_LOCAL_MACHINE\Software\Wow6432Node\Citrix\Dazzle\
EnablePreLaunch = false
d) HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Prelaunch
State = 0
e) HKLM\software/Wow6432Node\citrix\Dazzle
Key: DisableCacheOfResourceList
Type: Reg_SZ
Value: True
Also put in the following policy:
a) Disable Remove apps on Logoff and remove apps on exit using policies.
Problem Cause
The locally cached xml list for the user resources get outdated and require re-authentication to update.
Issue/Introduction
Citrix Receiver keeps prompting for authentication when accessed remotely
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