Error "Cannot start desktop" when you try to launch a published desktop

Error "Cannot start desktop" when you try to launch a published desktop

book

Article ID: CTX229163

calendar_today

Updated On:

Description

When you try to launch a published desktop, you may get the error message "Cannot start desktop" as shown in the screenshot below.

User-added image
Additionally, following events are recorded on the Delivery Controller and the StoreFront server:

Log Name: Application
Source:      Citrix Broker Service
Event ID:   1101
Level:        Warning
Description:
The Citrix Broker Service failed to broker a connection for user 'CONTOSO\admin2' to resource 'Windows 7'. The Citrix Broker Service cannot find any available virtual machines.
Please add more virtual machines to the site. If the problem is due to existing virtual machines not becoming available, see Citrix Knowledge Base article CTX126992.

Log Name: Citrix Delivery Services
Source:      Citrix Store Service
Event ID:    28
Level:         Warning
Description:
Failed to launch the resource 'Controller.Windows 7 $A17-5-CB719372-0001' using the Citrix XML Service at address 'http://MT-XenApp1/scripts/wpnbr.dll'. The XML service returned error: 'no-available-workstation'.

Log Name: Citrix Delivery Services
Source:      Citrix Store Service
Event ID:    0
Level:         Error
Description:
No available resource found for user contoso\admin2 when accessing desktop group Windows 7. This message was reported from the Citrix XML Service at address
http://MT-XenApp1/scripts/wpnbr.dll [NFuseProtocol.TRequestAddress].

Resolution

To resolve this issue, add more desktops to the Delivery Group the user is trying to connect to.

Problem Cause

This issue can occur if no free desktops/workstations are available for the user to connect to.

Additional Information

Note: In case of static desktop, make sure the user trying to logon is assigned to a machine OR there is an available machine for that user to connect to.