HDX applications fails to launch and errors out with an error message “Engine was not loaded, There is no Citrix SSL Server configured on the specified address. Error Number 183”.

HDX applications fails to launch and errors out with an error message “Engine was not loaded, There is no Citrix SSL Server configured on the specified address. Error Number 183”.

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Article ID: CTX228869

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Updated On:

Description

HDX applications fail to launch and error out with an error message “Engine was not loaded, There is no Citrix SSL Server configured on the specified address. Error Number 183”. 

User-added image

From the Client side trace we see that the client is unable to make TCP connection with the Second AG Vserver on custom port 8081.
Use the below two Network Connectivity check command to verify the connectivity.
1. CURL
2. nmap


1. The output of CURL Network command gives us the following error message :

Curl utility timing out to make a connection with https://example.com:8081 as per below result.
$ curl --sslv3 -v  -I https://example.com:8081
* Rebuilt URL to: https://example.com:8081/
*   Trying to connect to IP...
* connect to IP port 8081 failed: Operation timed out
* Failed to connect to example.com port 8081: Operation timed out
* Closing connection 0
curl: (7) Failed to connect to host.domain.com port 8081: Operation timed out

2. ​And the output of nmap gives the following output.

nmap command doesn’t shows that example.com server is listening on port 8081.
$ nmap example.com
Starting Nmap at 2017-10-04 20:33 UTC
Nmap scan report for example.com 
Host is up (0.0012s latency).
Not shown: 996 filtered ports
PORT     STATE  SERVICE
80/tcp   open   http
113/tcp  closed ident
8008/tcp open   http
8010/tcp open   xmpp

Nmap done: 1 IP address (1 host up) scanned in 46.81 seconds


 

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

Port 8081 was blocked on the Firewall. 
As soon as port 8081 was opened on the Firewall, user was able to launch the HDX apps.

Problem Cause

Custom port blocked on the External Firewall.