Dashboard and Filters data in Director does not match for the Connection failures

Dashboard and Filters data in Director does not match for the Connection failures

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Article ID: CTX228822

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Updated On:

Description

When there is a Client Connection Failure(s) in Dashboard, the detailed failure record may not be seen in Filters view.

Resolution

This is by design. The failure in Dashboard may have been counted by failing to reconnect to the existing session, and after that, the failure has been resolved by reconnecting to the same session successfully. In this case, there is no need to handle the failure because the last status of the session is success.

Problem Cause

This scenario happens when that is a connection failure reported on a specific session at one point in time. And the same session is launched fine in future. To reproduce, you can carry out the following steps.

1. Launch a session from a user on a delivery group and make sure it gets logged in Director (ex: Sessions Connected in Dashboard is set from "0" to "1").
2. Disconnect the session.
3. Try to reconnect to the session and fail to reconnect by Client Connection Failures (such as network disconnection between the client and the VDA).
4. See the database to check the connection failure is recorded in ConnectionFailureLog table with a foreign key (SessionKey) to the session entry. And the session entry in Session table will have a failure ID (FailureId).
5. Wait for some time for the consolidation to start.
6. After the consolidation, the connection failure record seen in step 4 will be written to FailureLogSummary table.
7. Try to reconnect and make sure the reconnection succeeds this time. This will wipe the failure entry for the session in Session table (set the FailureId to NULL).

Basically the Dashboard shows "all the failures which occurred over last one hour" and the Filters shows "the sessions which are failed at that moment in time".