Management CPU is pegged at 100% (monuploadd process)
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Article ID: CTX228713
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Updated On:
Description
Management CPU utilization continuously stays at 100%.
Resolution
Check which process is consuming high CPU via top command. This needs to be run under shell of SSH /PuTTy session.
If the process listed is monuploadd and/or syslogd, then the issue is happening due to CallHome feature which is enabled on the device.
To fix such issue:
1. Disable CallHome feature: disable ns feature callhome
2. Kill the respective daemon : kill <pid-of-monuploadd>
Problem Cause
The Call Home feature monitors your NetScaler appliance for critical error conditions. Call Home registers your appliance with the Citrix Technical Support server. If your appliance is successfully registered with the Support server, Call Home automatically uploads system data to that server in the event that one of the conditions occurs. The NetScaler Appliance keeps a full log of all upload events.
By default, the Citrix Call Home feature is disabled on the appliance. You must first enable the service to register the appliance for critical error conditions.
The appliance has to be registered to the Citrix Technical Support server before Call Home can upload the system data to the server when predefined error conditions occur on the appliance.to the Citrix technical support server.
When this feature is enabled, but the devices on which the feature is enabled is not registered, the process keeps trying to upload the logs but couldn't complete that due to lack of registration.
Issue/Introduction
This article is based on a case study and provides fix for 100% CPU utilization.
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