SDX 89xx: XenApp/XenDesktop Sessions Freeze/Timeout

SDX 89xx: XenApp/XenDesktop Sessions Freeze/Timeout

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Article ID: CTX228250

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Updated On:

Description

There may be instances where the user is connecting to NetScaler Gateway to access the XenAPP or XenDesktop and all of sudden the session is getting freeze or hung up.

For Example: VDI Sessions is getting struck after 2-5 minutes working.
After an disconnect an reconnect it works for another couple of minutes.
Disabling Application Flow Logging, changing the Tcp Profile and removing the ECC curves does not fix the problem.

One of the Supporting Log message under NSLOG is as below:
default ICA Message 1296774 0 :  "NS_ICA_ERROR: Invalid buffer length file no = 1191 line no = 2"



 

Resolution

Upgrade the VPX under SDX 89xx platform to 11.1 Build 54.121 nc. The link to download the same is as below.
https://www.citrix.com/downloads/netscaler-adc/components/netscaler-firmware-59xx-89xx.html


 

Problem Cause

TCP ZeroWindow issue is observed with TLS12 and TLSv11 protocol on SDX 89xx device.

Download speed starts decrementing from Higher Mbps/Gbps to Kbs and finally the session getting timed out and user would not be able continue to work on XenAPP or XenDesktop sessions.