XenMobile Servers (in cluster) goes into recovery mode while performing an upgrade
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Article ID: CTX228035
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Updated On:
Description
Use Case:
We have an existing XMS environment where multiple nodes have been configured in a cluster. While performing an upgrade from the current version to the recommended next version, the XMS nodes run into RECOVERY MODE.
Resolution
Once the SQL service account is granted with the right privileges, reboot the XMS node. This time, since the SQL service account has the right privileges, the DB gets updated. The upgrade is successful.
Here are the recommendations of how to perform an upgrade when you have the XMS configured in a cluster.
For example: We have three XMS nodes configured in a cluster.
- Take a snapshot of each of the XMS nodes configured in a cluster.
- Take a full DB backup of the XenMobile DB in SQL
- Make sure that the communication is established between the XMS and the SQL database.
- To perform a quick check Log onto the XMS using the CLI.
- Go to option [0] Configuration > [3] Database.
- Hit enter [y] to proceed at Reboot is required to save changes.
- Enter the SQL password
- If the details provided are correct, there are no error thrown on the screen which indicates that the communication is established.
- Make sure that the SQL service account provided in the XenMobile server always has the right set of privileges. (For more info please refer to XenMobile Database Requirements in this article)
- Now start the update of the .bin (upgrade) file with the oldest node.
- Using the admin console of XMS, navigate to Settings > Release Management
- Browse and select the .bin (upgrade) file.
- Once the upload is successful, shut down the oldest node.
- Move on to the second node, perform steps 5,6 and 7.
- Mode on to the third node, perform steps 5,6 and 7.
- Now power up the oldest node
- Logon to admin UI and verify if the upgrade details under Setting > Release Management and double check to make sure all configurations are intact.
- Bring up the 2nd XMS node and perform the same checks as defined in the step (10) above. (Note: Bring up one node at a time)
- Bring up the 3rd XMS node and perform the same checks as defined in the step (10) above.
Roll back procedure
- Shutdown all the nodes
- Revert the snapshots taken for each of the nodes before upgrade
- Revert the snapshot of the DB taken before upgrade
- Power on one node and check if everything is fine
- Power on the remaining nodes.
Problem Cause
In a certain use case we found that the XMS nodes were moving into RECOVERY MODE while trying to power them up after the .bin files have been updated.

On debugging we have found that SQL service account privileges were deprecated.
- When you bring up the oldest node, as part of the upgrade process the XMS SQL DB is also being updated.
- During this process if the SQL service account does not have the right privileges, then update fails sending the node into RECOVERY MODE.
Additional Information
If you still are encountering issues please contact Citrix Support.
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