App Layering PVS Agent error registering to ELM "Could not create SSL/TLS secure channel"

App Layering PVS Agent error registering to ELM "Could not create SSL/TLS secure channel"

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Article ID: CTX227957

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Updated On:

Description

When configuring the App Layering Provisioning Services (PVS) Agent on the PVS server, the error "Could not create SSL/TLS secure channel" occurs.

Resolution

Upgrading the App Layering PVS Agent to version 4.4+ will resolve this issue.

This issue can also be confirmed within the logs on the PVS server. Check these logs for something similar to the following to confirm:

C:\Program Files (x86)\Citrix\Agent\Logs
  • The first line in the logs will contain the version of the App Layering Agent you are running - Versions below 4.4 will experience this issue
  • 2017-01-23 12:34:55,543 WARN 1 ELMWebClientService: Reconnect attempt 0 exception System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
       at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)



 

Problem Cause

Known issue with older versions of the PVS Agent's use of ciphers. It is also possible that the environment has SSL/TLS locked down