Error "Your smart card does not have a valid certificate" when using Citrix Receiver for iOS 7.3 with iOS 11
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Article ID: CTX227952
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Updated On:
Description
This article is intended for Citrix administrators and technical teams only.
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.
When users try to connect to Storefront or NetScaler Gateway using smart cards (PIV or CAC) using Citrix Receiver 7.3 for iOS or earlier versions on iOS 11 devices, users may receive the following error message “Your smart card does not have a valid certificate”.

However, users connecting from iOS 9 and 10 devices will not face this error and will be able to use smart cards to authenticate to Storefront or NetScaler Gateway.
Resolution
There is NO workaround for this issue. Citrix recommends users who are using smart cards with their Citrix Receiver for iOS not to upgrade to iOS11 until the updated version of Receiver is made available.
Citrix is working towards resolving this issue. Once resolved, a new version will be updated in the App Store.
Problem Cause
Citrix has identified that the error is due to a third-party-dependent SDK used for smart card authentication that is not compatible with iOS 11.
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