SAML with limit visibility on the application on the Delivery Controller using a Security Group
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Article ID: CTX227760
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Description
- When we publish new App in Delivery Group that uses SAML and set limit visibility on the application for an Active Directory Security Group, application icon will not enumerate.
- The application will enumerate when through Storefront Server.
- If user is added explicitly to the application visibility, the application Enumeration works.
Environment
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Resolution
- On the StoreFront Server.
- Open the Registry Editor
- Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters\
- Create a new DWORD "CacheS4UTickets" and set the decimal value to 0 to disable it.
- Reset the IIS.
Problem Cause
- The results of XML Service SID enumeration might be cached because of Kerberos ticket caching, causing a delay in changes to users’ group memberships being reflected in their available published resources. By default, the duration of this caching is 15 minutes
Issue/Introduction
SAML with limit visibility on the application on the Delivery Controller using a Security Group
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