XenMobile: Second Profile Installation Failed on iOS

XenMobile: Second Profile Installation Failed on iOS

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Article ID: CTX227633

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Updated On:

Description

Logs 

" 2017-09-05T16:09:55.988+0530 ",<MDM>,ERROR (2),__48-[X1MDMEnrollFlowController createEnrollSession]_block_invoke,"request to create enrollment session unauthorized with 401",Active,com.apple.main-thread,403,Secure Hub,/jenkins/workspace/iOS_SecureHub/AppStore/Me@Work/Me@Work/Controller/X1MDMEnrollFlowController.m,1212 
" 2017-09-05T16:09:55.989+0530 ",<MDM>,DETAIL (5),-[X1MDMEnrollFlowController handleServerError:errorMessage:],"Error Message for auth error is (null)",Active,com.apple.main-thread,403,Secure Hub,/jenkins/workspace/iOS_SecureHub/AppStore/Me@Work/Me@Work/Controller/X1MDMEnrollFlowController.m,2102 
" 2017-09-05T16:09:55.989+0530 ",<MDM>,ERROR (2),-[X1MDMEnrollFlowController handleServerError:errorMessage:],"handleServerError response 401 with title and detail text Citrix Secure Hub Please check your credentials. You may have mistyped them.",Active,com.apple.main-thread,403,Secure Hub,/jenkins/workspace/iOS_SecureHub/AppStore/Me@Work/Me@Work/Controller/X1MDMEnrollFlowController.m,2144 
" 2017-09-05T16:09:55.992+0530 ",RECEIVER_UI,ERROR (2),-[UICoordinator showErrorMessage:options:delegate:dismissed:],"Root cause for the error is : (AuthCredentials error 19.)",Active,com.apple.main-thread,403,Secure Hub,/jenkins/workspace/iOS_SecureHub/AppStore/Me@Work/Coordinator/UICoordinator.m,634 

Resolution

Follow the below steps:
  • Reboot the server once.
  • Ensure XenMobile have valid license activited.
  • Ensure the server certificate on NetScaler Gateway and on Xenmobile is in complete chain.
  • Ensure the CA Root cert is present on NetScaler.
  • Verify if under XenMobile Admin Console, enrollment profile if we have set device limit per user if the number exceeds the number mentioned than it is expected behavior of the device to fail on second profile installation
Note: Hence we can increase the value set on the enrollment profile or remove the inactive/unused devices from XMS and try again.

Problem Cause

The enrollment profile was set to allow only certain number of devices per user.

Issue/Introduction

This article summarizes the steps to follow if the enrollment is failing for iOS devices during second profile installation and we get the following error "Profile Installation Failed. The SCEP server configuration is not supported"