Secure Mail does not sync emails after upgrading to version 10.6.0

Secure Mail does not sync emails after upgrading to version 10.6.0

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Article ID: CTX227528

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Updated On:

Description

> Emails are not syncing for users after the Secure Mail update to 10.6.0.
> We will see the following Socket errors in the logs:

2017-07-25T06:17:37.266-0400 AGTunneler INFO (4) -[AGSocket connect:withPort:] -[AGSocket connect:withPort:]: CallOriginal_connect (errno = 36 - 'Operation now in progress'), fd = 69
2017-07-25T06:17:37.266-0400 AGTunneler INFO (4) -[AGSecureSocket connect:withPort:] connect return value: -7986
2017-07-25T06:17:37.393-0400 AGTunneler INFO (4) -[AGSocket connect:withPort:] -[AGSocket connect:withPort:]: CallOriginal_connect (errno = 56 - 'Socket is already connected'), fd = 69
 

Resolution

The Socket error - “Socket is already connected” causes the application not to talk to the backend server.
The fix for this issue is in the MDX toolkit version 10.6.15.
Upgrade to latest MDX Toolkit or migrate to Public Store.

Problem Cause

Issue with the MDX Toolkit version.