Management GUI Unavailable After Software Upgrade

Management GUI Unavailable After Software Upgrade

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Article ID: CTX227345

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Updated On:

Description

When attempting to login to the management interface the page is not displayed correctly and login is not possible. 
Symptoms can vary somewhat, but often rdx-related script errors are seen.

Resolution

  1. Connect to the NetScaler appliance via SSH.
  2. Run command: show vpn parameter
    Vpn Parameters
  3. Check if VPN UI THEME is set to CUSTOM
  4. Run command: set vpn parameter -UITHEME DEFAULT
  5. Test if the GUI is now available.

Problem Cause

This can happen when the unit is upgraded while a gateway customization is still in place.
When using this method, the customization is saved into a customtheme.tar.gz located in /var/ns_gui_custom/ directory.  
The .tar file will contain all the GUI files for the build the .tar file was created on. 

If the appliance is upgraded, it will still use the customtheme.tar.gz, however the files included are for the older build/version.
This can lead to issues with accessing the Management GUI. 

Please note that in version 11+ there is now an option to add portal themes to the vservers which allows custom themes to be created within the GUI.

Issue/Introduction

Management GUI unavailable after software has been upgraded