Black Active Border Around Published Application for Profiles Created Using Runonce.exe /AlternateShellStartup

Black Active Border Around Published Application for Profiles Created Using Runonce.exe /AlternateShellStartup

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Article ID: CTX227295

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Updated On:

Description

Clicking on menu items inside an AllScripts published application is sluggish and takes 20-30 seconds to load the menu items. The issue does not happen in an RDP session.

Resolution

Configuring Runonce.exe /AlternateShellStartup as a logon script fixed the issue with the lag inside the application.

However, this created a new issue where the published application now has a black active border around it - This was eventually resolved by deleting HKLM\SOFTWARE\Microsoft\Active Setup\Installed Components\{2C7339CF-2B09-4501-B3F3-F3508C9228ED} from the VDA's - This is Active Setup for themes.


Problem Cause

Issue related to the user profile. When a user profile is created by logging into a published desktop or RDP to the server, the issue is not observed. The issue is observed when profiles are created by just launching the published application.

Issue/Introduction

Clicking on menu items inside an AllScripts published application is sluggish and takes 20-30 seconds to load the menu items. The issue does not happen in an RDP session.