book
Article ID: CTX227272
calendar_today
Updated On:
Description
When end users log into a virtual machine with Elastic layering enabled, they see the error "We were unable to attach your User Layer. Any changes you make to application settings or data will not be saved. Be sure to save any work to a shared network location." Details: "Access to the path "\\fileshare\...." is denied.
Resolution
App Layering uses the file share path configured in the ELM management console to set registry keys in published images, which tell those images where to look for their user layers and elastic assignments. These registry keys are set at the time of publishing, so if the path has changed since the last time the image was published, the values will no longer align.
First, check in the ELM Management console to confirm the current file share location. Go to System->Settings and Configuration->Network File Shares

Now, make sure the highlighted file share location is the same as the registry key set on the published image where we saw the error. Open RegEdit, and navigate to HKLM\Software\Unidesk\ULayer and check the "RepositoryPath" key

Finally, make sure that you are able to navigate to that directory on your virtual machine. Open up file explorer and check. If you do not have the correct share permissions, please refer to this article for additional configuration assistance:
https://docs.citrix.com/en-us/citrix-app-layering/4/layer/enable-user-layers.html
Problem Cause
This could be related to permissions issues, the file share location changing since the image was published (registry key outdated), or the file share configuration in the ELM pointing at the wrong location.
Issue/Introduction
Make sure that your file path is pointing at the correct location