Policies and Applications are not pushing to iOS devices from Xenmobile (Proxy Enabled Environment)

Policies and Applications are not pushing to iOS devices from Xenmobile (Proxy Enabled Environment)

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Article ID: CTX227187

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Updated On:

Description

The device information is not fetched completely on XenMobile and under device setting on XenMobile console we don't see any assigned delivery group.

The test connectivity is successful

In the Debug logs you can see  : 
| ERROR | pool-47-thread-1 | com.notnoop.apns.internal.ApnsConnectionImpl | Couldn't connect to APNS server java.net.SocketException: Malformed reply from SOCKS server

Resolution

Since the XenMobile is configured with proxy, the traffic will go through proxy to the internet, hence if  you have configured http or https with auth.

Image of proxy server setup

Image of proxy server setup

The following table for supported target types for each proxy server type.

Proxy type

Supported targets

SOCKS

APNS

HTTP

APNS, Web. PKI

HTTPS

Web, PKI

HTTP with authentication

Web, PKI

HTTPS with authentication

Web, PKI



Test by removing APNS from them and configure again either configure the proxy without auth or Enabled SOCKS on Proxy Server and add APNS under XenMobile CLI for APNS.

Note : Any changes in Proxy settings require reboot .

If you have configured APNS in multiple options like http/socks/https - it is advisable to use on of these since it will  help in narrowing down the issue and having multiple proxy options for single component can create ambiguity . 

The following table for supported target types for each proxy server type.

Proxy type

Supported targets

SOCKS

APNS

HTTP

APNS, Web. PKI

HTTPS

Web, PKI

HTTP with authentication

Web, PKI

HTTPS with authentication

Web, PKI



 

Problem Cause

The APNS traffic doesn't work with Auth and can be configured as http or socks (both without authentication)
 

Proxy type

Supported targets

SOCKS

APNS

HTTP

APNS, Web. PKI

Hence if the server is configured for http / https with auth you will have to configure APNS on SOCKS.

Issue/Introduction

This article summarizes the steps to verify when the applications and policies are not pushing to the devices particularly when XenMobile environment is configured with proxy

Additional Information

https://docs.citrix.com/en-us/xenmobile/server/install-configure/proxy-servers.html