XenApp 7.x - Intermittently unable to launch application , Studio shows Active Desktop Session

XenApp 7.x - Intermittently unable to launch application , Studio shows Active Desktop Session

book

Article ID: CTX226606

calendar_today

Updated On:

Description

Intermittently users are not able to launch a published application successfully. No error message displayed for the user. Desktop Studio shows an Active Desktop Session for the user. However the Delivery group is an Application only delivery group and there is no Desktop published for the user. Removing the Desktop Session from the Studio will allow the user to successfully launch the published application.

Resolution

On the Storefront server make the following changes for the Client Interface Settings:

1. Uncheck "Auto Launch Desktop" option
2. Change the Multi-click Duration from the default 3 seconds to 5 seconds. 

Problem Cause

Multiple applications were launched within few seconds resulting in the problem.

Additional Information

https://www.citrix.com/blogs/2014/03/29/multiple-launch-prevention-in-citrix-receiver-for-web/
https://www.citrix.com/blogs/2014/10/13/learn-how-storefront-2-6-administration-just-got-easier/