Published desktop stuck at logon with Greyscreen and Published app fails to launch at Starting

Published desktop stuck at logon with Greyscreen and Published app fails to launch at Starting

book

Article ID: CTX226605

calendar_today

Updated On:

Description

Published desktop stuck at logon with Greyscreen
 
image.png


Published application stuck at Starting...

image.png


Event ID 1005 (Source: CtxUvi) is recorded in the System event log of the VDA indicating that the CtxUvi has disabled itself. The details tab of the event includes the details about the module that causes the problem. In the example below, the problem is related to the Graphics Helper hook.

CtxUvi-Event1005

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

1. Disable the Group policies that were setup to modify the values under :

[HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook\AppInit_Dlls [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook\AppInit_Dlls

2. Reboot VDA.

These steps will resolve the problem. If the registry key modifications are required, these changes can be made in the Master image manually and rolled out to the MCS/PVS VDAs.
 

Problem Cause

CtxUvi driver not loading the hooks correctly.

Dynamic changes to the \Citrix\CtxHook\AppInit_Dlls registry keys will cause CtxUVI service (new Citrix Hooking mechanism) to disable itself there by resulting in none of the Citrix Hooks properly getting loaded. So it is recommended not to use Group Policies to control the above registry keys.

Additional Information

Grey Screen when launching the applications or desktops - Ctxuvi event ID 1005 and 1003