Updating to Secure Hub 10.5.5 causes Passcode prompt to appear repeatedly

Updating to Secure Hub 10.5.5 causes Passcode prompt to appear repeatedly

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Article ID: CTX226492

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Updated On:

Description

You may find that after upgrading to Secure Hub 10.5.5 on Android, the device repeatedly requests the Passcode to be entered (even though the Passcode entered is known to be valid).
Upon investigation of the Secure Hub log files, you may notice an error message which states "SecretVaultProvider:Failed to open secret vault genericVault"

Resolution

Upgrade to Secure Hub 10.5.15 (or newer) and begin a new enrolment of the affected device.

Problem Cause

The Secure Hub log files record the error message "SecretVaultProvider:Failed to open secret vault genericVault" after upgrading from an older version to Secure Hub version 10.5.5.
The error message seen is an indication that the app is failing to open up the encrypted vault named 'genericVault'.
Because of this error message, Secure Hub 10.5.5 is not able to save any passwords, PINs or security certificates to the referenced vault.
This may result in repeated requests for the Passcode to be entered and no access to the vault granted even with a known good Passcode provided.

Issue/Introduction

You may find that after upgrading to Secure Hub 10.5.5 on Android, the device repeatedly requests the Passcode to be entered even though the Passcode used is known to be valid. Upon investigation of the Secure Hub log files, you may notice an error which states "SecretVaultProvider:Failed to open secret vault genericVault"