Error message “No data is available.Try running a health check.” shows up under resources in Cloud Connector

Error message “No data is available.Try running a health check.” shows up under resources in Cloud Connector

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Article ID: CTX226453

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Updated On:

Description

The test connectivity on Cloud Connector machine is successful however the domain still shows error with message "No data is available.Try running a health check.If the problem persists,open a support ticket". Below is the snapshot for same.

User-added image
Because of this enrolment will fail immediately after entering username and password on Secure Hub and user will get an error message "incorrect username or password".
However the SHP for same credentials work successfully. 

Resolution

The Citrix cloud connector needs TCP 443 opened for all outbound communications to the Citrix Managed Control plane.
Additionally, the Host management and Machine Creation Management capabilities of Citrix cloud also require TCP 9350-9354 opened for communications to the Citrix Managed control plane.

https://support.citrix.com/article/CTX101810&searchID=21827039

Along with the ports following addresses need to be contactable in order to properly operate and consume the Citrix Cloud services.

XenMobile

https://*.citrixworkspacesapi.net

https://*.cloud.com

https://cwsproduction.blob.core.windows.net/downloads

https://*.servicebus.windows.net

Additional requirements

http://docs.citrix.com/en-us/xenmobile/xenmobile-service.html

https://*.citrix.com

https://*.citrixworkspacesapi.net

https://*.cloud.com

https://cwsproduction.blob.core.windows.net/downloads

Additional requirements

http://docs.citrix.com/en-us/xenmobile/xenmobile-service.html


https://docs.citrix.com/en-us/citrix-cloud/overview/requirements/internet-connectivity-requirements.html?_ga=2.264502671.1637251173.1501135165-1288963103.1438927164

Problem Cause

As per the Citrix Document, pre-requisites are not met and theTCP ports 9350-9354 needs to be open 

Issue/Introduction

The domains under resources tab on Citrix Cloud portal shows down intermittently- XenMobile .

Additional Information

https://support.citrix.com/article/CTX101810&searchID=21827039

https://docs.citrix.com/en-us/citrix-cloud/overview/requirements/internet-connectivity-requirements.html?_ga=2.264502671.1637251173.1501135165-1288963103.1438927164