Error "Set device encryption on device to use this app" on Android device

Error "Set device encryption on device to use this app" on Android device

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Article ID: CTX226086

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Updated On:

Description

Apps install correctly and no issues are shown on the server. However, while opening the app on the device, the message "Set device encryption on your device to use this app" is displayed. The device storage is encrypted still we see this issue.

Resolution

To resolve the issue, update the settings on the device to require a PIN on startup.   The exact process can vary from device to device  version and most likely it will be the same steps:
  1. Open your device's Settings app   Settings.
  2. Under "Personal," tap Security.
  3. Tap Screen lock.
  4. To choose your screen lock, tap PatternPIN, or Password.
  5. You'll be asked to "further protect this device" by requiring your PIN, pattern, or password when your device starts. The first time that you choose this setting, it will encrypt your device.
    1. Select Require to start device.
    2. Tap Continue.
  6. Set your PIN, pattern, or password. Tap Continue.
  7. Confirm your PIN, pattern or password. Tap Ok.
Now, remove SecureHub and reinstall with the latest version and re-enroll into the XenMobile. 

Problem Cause

Device did not have a PIN configured on startup