Application Launch Fails with "Unknown client error 1110" When Using EDT/DTLS on NetScaler Gateway

Application Launch Fails with "Unknown client error 1110" When Using EDT/DTLS on NetScaler Gateway

book

Article ID: CTX226014

calendar_today

Updated On:

Description

Some traffic patterns cause application launch through NetScaler Gateway to fail if EDT is enabled on Virtual Desktop Applications.

When NetScaler Gateway is terminating DTLS connections, if the DTLS packet happens to be fragmented, the DTLS stack incorrectly drops this fragmented packet.

This results in an application launch failure with the following popup:

User-added image

Launching the application over TCP works, however UDP fails.

This can happen when ICA traffic travels through a network where the MTU is less than 1500 bytes.

Resolution

The fix for this issue has been developed and will be available in NetScaler 11.1 build 55.x and 12.0 build 53.x.

  • 11.1 build 55.10 Maintenance Release - available on the Citrix download page at this location.
  • 12.0 build 53.6 Maintenance Release - available to download at the following location

Problem Cause

A bug (issue ID#686774) in NetScaler DTLS layer caused the drop of DTLS frames fragmented in IP layer which resulted in the loss of EDT data.

Issue/Introduction

Application Launch Fails with "Error: 1110" When Using EDT/DTLS Through NetScaler Gateway

Additional Information

More Information About Enlightened Data Transport can be found at the following resources
Citrix Documentation - Adaptive transport
Citrix Documentation - When to Use Enlightened Data Transport Support