WEM Agent Connection error: "Broker Server Name or Broker Port Error"

WEM Agent Connection error: "Broker Server Name or Broker Port Error"

book

Article ID: CTX225919

calendar_today

Updated On:

Description

WEM Agent fails to connect to the WEM Broker and shows the following error when manually refreshing the WEM cache using this command:  AgentCacheUtility.exe -refreshcache:

"Broker Server Name or Broker Port Error"

User-added image
 

Resolution

#1: Add "Site Name" string with the exact value of "[ConfigurationSet]" to the AD policies for all WEM agents and restart the Norskale Agent Host Service on the WEM Agent.
***The Configuration Set is retrieved from the WEM Administration console and is only needed if it is not the Default value.***
FYI:  This is a way to manually set this value, however, as of WEM 4.3 and later, this should be automatically set by adding the Agent machine to the "Active Directory Objects" section for the applicable "Configuration set" inside the WEM Administration Console.  

#2: Launch the WEM Admin Console and increased the value for "Broker Service Timeout" from 2000 ms to 60000 ms (Present under "Agent Options" in "Advanced Settings"), increase the value of "Agent Extra Launch Delay from "0" to "30000" (Present under "Service Options" in "Advanced Settings") and uncheck "Bypass ie4uinit Check" in the same section..... apply the settings and restart the WEM Agent. 
***These setting values can vary depending on the amount of timeout or latency that is occurring and only if timeout is reached accordingly to the Agent Host Service Debug logs on the WEM Agents.***

Problem Cause

WEM "Configuration set" via the WEM Administration console was changed from the default value but the new value was not specified in the WEM Agent settings.

Plus, when the WEM Agent first attempts to reach out to the WEM Broker to make a connection, there is a latency in the network or bad timing with the communication to Active Directory causing a timeout error to be reached while WEM Agent is first attempting to communicate with the WEM Broker.