XenDesktop 7.x: Citrix Studio shows "Registration Missing" and Fault as "Stuck on Boot" for MCS Based Machines
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Article ID: CTX225850
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Updated On:
Description
- MCS based VDA's "Fault State" in Studio shows as “Stuck on Boot” and the machines get populated under ‘Registration Missing’ tab in Delivery Group’s Details tab even though all the machines are actually registered and users can launch Apps and Desktops successfully.
- This issue happens when the VDA's are hosted on Nutanix Hypervisor.
- Restarting the Delivery Controllers Or Restarting the Desktop Service or Rebooting the machines from Hypervisor fixes the issue. The issue is only see when machines are rebooted from Citrix Studio.
- Increasing the value of below registry keys under HKEY_LOCAL_MACHINE\Software\Citrix\DesktopServer\ does not fix the issue.
MaxTimeBeforeStuckOnBootFaultSecs
MaxTimeBeforeUnregisteredFaultSecs
- There is no delay during machine reboot and before the timeout period for the above registry keys expires the "Fault status" shows as "None". After the timeout period expires the "Fault Status" changes to "Stuck on Boot"
Environment
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Resolution
The issue seems to be addressed in Nutanix Acropolis MCS Plugin v1.1.2.0 . Contact Nutanix to get Nutanix Acropolis MCS Plugin v1.1.2.0.
You can download this plugin from my.nutanix.com.
Problem Cause
This issue was seen to occur in some cases due to a race condition between the registration and the power state reporting, which caused the broker to incorrectly infer the fault state for the machine.
Issue/Introduction
MCS based VDA's "Fault State" in Studio shows as “Stuck on Boot” and the machines get populated under ‘Registration Missing’ tab in Delivery Group’s Details tab even though all the machines are actually registered and users can launch Apps and Desktops successfully.
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