Reboot Schedule Set on Delivery Group Prior to Controller Upgrade Fails to Apply
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Article ID: CTX225785
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Updated On:
Description
After upgrading Delivery Controller to 7.13 from a previous version , the Reboot schedules that were set prior to upgrade fail to apply .
Resolution
1. Open PowerShell as an Admin ; asnp citrix*
2. "Get-BrokerRebootSchedule" to fetch the current Reboot Schedules
3. Remove-BrokerRebootSchedule -DesktopGroupName 'NameOfDG'
4. Connect to Studio console : Edit Delivery Group > Set Reboot Schedule again . (Wait for 15 minutes from current time in order to test it)
If it still doesn't work ,
1. Shut down the affected VDAs
2. Put Delivery Group to maintenance mode
3. Delete the Machine Catalog
4. Recreate the Machine Catalog
5. Add the Machines back into the Catalog
6. Take Delivery group out of Maintenance mode
7. Set Reboot Schedule from Delivery group Properties again .
* This issue was addressed with XenApp / XenDesktop 7.13 with LC6766 , if issue still persists contact Citrix Technical Support
(https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-13/whats-new/fixed-issues.html)
Problem Cause
After the controllers are upgraded , When BrokerAgent tries to write a CDE event about the message delivered, it ends up throwing an exception resulting in Broker getting a Fault error which translates to the VDA rejecting the message. So, no reboot is attempted.
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