During New MAM Enrollment End User Receives - "An error occurred. The enrollment will stop"

During New MAM Enrollment End User Receives - "An error occurred. The enrollment will stop"

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Article ID: CTX225722

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Updated On:

Description

During enrollment MDM proceeds successfully, but the MAM enrollment fails with "An error occurred. The enrollment will stop". 

On Android you may experience the following: 

Enrollment will successfully complete, however Secure Hub is enrolled only in MDM mode not MAM.

Scenarios that Identify failed enrollments:

  • If PIN authentication is enabled, the user is not prompted to enter the PIN and Secure Hub prompts the following error: "Secure Hub has stopped"
  • The only option displayed is "Home" within Secure Hub. The options such My Apps and Store are not displayed.

Resolution

Confirm TLS v1.2 is enabled in the Citrix Gateway VIP settings. 


Problem Cause

Though there could be multiple reasons, we have found that the above error is displayed when TLS v1.2 is not enabled on the Citrix Gateway VIP. Please make sure you have the TLS v1.2 enabled and try again.

Issue/Introduction

MDM Enrollment go through however it fails at the MAM portion