GUI, CLI and Dom0 Access of NetScaler SDX SVM is Lost Due to Excess Logging in VAR/Log

GUI, CLI and Dom0 Access of NetScaler SDX SVM is Lost Due to Excess Logging in VAR/Log

book

Article ID: CTX225710

calendar_today

Updated On:

Description

In case you are not able to access your SDX SVM via GUI or CLI, check the filesystem via accessing the Dom0 of the hardware. If Dom0 is also not accessible try to connect to console of the SDX. Once connected check for the file system /var/log. If the log directory is 100% full we might be hitting the BUG0683171.     

Filesystem  SizeUsedAvailUse%Mounted on
/dev/md_d0p24.0G4.0G0100%/

This is indicating that there is an issue with disk space.

Resolution

The issue is fixed in NetScaler 12.0 44_1+ and 11.1 54_4+.

For version 11.1 53.11, apply the following workaround:

1. Log on to dom0 (If Dom 0 is not accessible use Netscaler Console).
2. Run the df command to check the available disk space.
3. If the disk space is full (100%) and the /var/log directory has large log files, run the rm <fileName> command to delete files and free space.
4. Check the permission of "opt/xensource/bin/rotate_logs_by_size" file by running the Is -I command:
# ls -l /opt/xensource/bin/rotate_logs_by_size
If the result appears as "-r--r--r-- 1" and with no x characters, as in the following example, you need to change the permission.
-r--r--r-- 1 root root 3794 Mar 27 13:48 /opt/xensource/bin/rotate_logs_by_size
5. Run the chmod 555 to change the file permission.
# chmod 555 /opt/xensource/bin/rotate_logs_by_size
Recheck the file permission. For example:
# ls -l /opt/xensource/bin/rotate_logs_by_size
-r-xr-xr-x 1 root root 3794 Mar 27 13:48 /opt/xensource/bin/rotate_logs_by_size
6. Reboot the system for the above changes to take effect immediately, or wait for a few hours for the changes to become effective.

Problem Cause

If system logs are not rotated properly, over time they consume too much disk space. This causes the XenServer server to run out of disk space and creates unexpected system behavior.

Issue/Introduction

GUI, CLI and Dom0 access of NetScaler SDX SVM is lost due to eccess logging in VAR/Log directory.