Workspace control Stops Working

Workspace control Stops Working

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Article ID: CTX225625

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Updated On:

Description

  • Attempts to take over an active session from another client device through the use of Workspace Control will cause the connection attempt to hang at the welcome screen before ultimately failing.
  • The existing active session will continue to persist, but the new connection attempt will never complete.
  • On the Director you will see the session for the user in the logging off state.
  • The issue occurs only when using VMware Application Volume Manager.
          
 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  • Open Regedit on the VDA.
  • Go to HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Ica\Session\#\Connection\SessionInPreLogoff change the value of the key from 1 to 0.
  • This will disable the PreLogoff on the VDA.
  • Now the users will be able to roam between the sessions without any issues.


Note: If the issue still persists after following the above steps, disable the VMware App Volume Manager and call Citrix Support for further assistance.


Problem Cause

The key used to indicate whether a VDA is entering a logoff state, HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Ica\Session\#\Connection\SessionInPreLogoff, is being created when using VMware Application Volume Manager or any other application volume managers.

Issue/Introduction

Attempts to take over an active session from another client device through the use of Workspace Control will cause the connection attempt to hang at the welcome screen before ultimately failing