With StoreFront Authentication only gateway users stuck detecting Citrix workspace app

With StoreFront Authentication only gateway users stuck detecting Citrix workspace app

book

Article ID: CTX225270

calendar_today

Updated On:

Description

When the gateway is configured for "Authentication only", when the user goes to the store in their web browser, after opening Citrix Workspace Launcher it gets stuck and does not proceed to the next screen.

Resolution

In the StoreFront gateway configuration settings, change the usage / role from "Authentication only" to "Authentication and HDX routing", even if due to optimal gateway routing the gateway is only used for authentication. For more information see Configure Citrix Gateways.


Problem Cause

When a store website uses Citrix Workspace launcher to communicate with Citrix Workspace app, Citrix Workspace app requires an STA ticket to connect through the gateway to respond. When the gateway is configuration for "Authentication only" StoreFront does not provide STA tickets.