XenDesktop 7.11: Failed Desktop/Server OS count incorrect on Director Dashboard

XenDesktop 7.11: Failed Desktop/Server OS count incorrect on Director Dashboard

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Article ID: CTX225139

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Updated On:

Description

For XenDesktop 7.11 and Lower: Failed Desktop/Server OS count on the Director Dashboard does not change even after all the desktops are registered and in Use

Environment

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Resolution

- MonitorData.MachineFailureLog is used to pull the information to the Director Dashboard using OData API.
- Verify the FailureEndDate Column of the MonitorData.MachineFailureLog table , you should see a lot of Null Entries on this Column.
- Take Full Backup of Monitor Database and execute the following query:

1. The below query will give you total count of records which are stuck in failed state(The count should match the Desktop/Server OS failed machine count)

SELECT * FROM [MonitorData].[MachineFailureLog]
      WHERE FailureEndDate IS NULL

2. Execute the below query to Remove those entries from the database.(Note: This is a temporary fix)

DELETE FROM [MonitorData].[MachineFailureLog]
      WHERE FailureEndDate IS NULL

- Upgrading XenDesktop controllers and Director servers to 7.12 or newer is recommended for permanent fix as the issue would come up again on lower versions in a day or so.

Problem Cause

- The issue happens as the Monitoring Service fails to update the FailureEndDate field for all the Desktops stuck on Director Dashboard in the MonitorData.MachineFailureLog Table of the Monitoring Database.