Not able to change log format to CEF using appfw settings

Not able to change log format to CEF using appfw settings

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Article ID: CTX225026

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Updated On:

Description

> set appfw settings CEFLogging ON
ERROR: Import limit should be greater than the current total imported objects size.

Resolution

Earlier when we attempted to import an object which exceeded the configured Limit, we used to display an error message.

This behavior got changed in 11.0 and 11.1 builds.
We somehow allowed import of an object which exceeds the configured Limit.

Max Limit for import object is 128mb.

Due to the issue  we started ignoring configured/max limit users were able to import objects greater than the configured/max limit, and once it is allowed and than users try to make changes to appfw settings such as CEF they are not allowed to do it and we throw an error message back to the Client "
ERROR: Import limit should be greater than the current total imported objects size."

This issue has been fixed in Netscaler Release
a) 11.0 71.x
b) 11.1 54.x.


> set appfw setting -importsizelimit 268435457
[# 682219] - issue id (refer release notes)
 
This limit is now extended from 128 MB to 256 MB.
Execute the following set command from the CLI to change the value to meet your requirement:

> set appfw setting -importsizelimit

Maximum value: 268435456
Minimum value: 1
Default: 134217728



Where we've reintroduced the check to verify the importsize to check before every import if the size exceeds the configured or max import limit.
And we've increased the max import allowed limit to 256mb from 128mb.

Problem Cause

This was caused due to an internal bug.