WEM Console Access error: "You are not registered as a Workspace Environment Management Administrator. Therefore, you are not allowed to access the service..."

WEM Console Access error: "You are not registered as a Workspace Environment Management Administrator. Therefore, you are not allowed to access the service..."

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Article ID: CTX224998

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Updated On:

Description

When attempting to connect to the WEM site using the WEM Admin console, the following message appears:
"You are not registered as a Workspace Environment Management Administrator.  Therefore, you are not allowed to access the service.  Please contact your Workspace Environment Management Administrator to gain access."

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Receiving the following error when trying to connect the WEM Administrative Console to the Infrastructure Server - "You are not registered as a Workspace Environment Management administrator. Therefore you are not allowed to access the service. Please contact your Workspace Environment Management administrator to gain access." We have tried connecting the admin console on the same server that has the infrastructure server server role (server 2008R2) as well as another Server 2012 vm in the same environment. Initially tired connecting using a service account set up specifically set up for WEM which was granted full admin access to the infrastructure server (including login as a service) and the SQL dbowner role assigned to the WEM instance. We also tried with a Citrix Admin account and a Domain Admin , same error was faced.
After recreating a new Database getting error "Not able to connect to the specified Infrastructure Server" and on the Database Management log saw error reading Database.
Found out that on the Broker service configuration the service account was not used so added the account and was able to connect to the Console.

Resolution

The account being used to launch the WEM Administration Console must be added to the "Configured Administrator List" inside the WEM Administration Console.
  1. Launch the WEM Administration Console as a WEM Administrator.
  2. Navigate to "Administration" > "Administrators"
  3. Click "Add" & Add the User Object or the Group that the User in question is a part of.
  4. Right click on the newly added User or Group, change the value of "State" to Enabled" and change the value of "Permissions" to the required level of access needed.
  5. If "Global Administrator" is checked, the settings for this user will apply to all "Configuration Sets".  Otherwise, individual "Configuration Sets" must be selected.
  6. Be sure to add the proper required permissions needed and change the value of "State
  7. After saving your changes, close the WEM Administration Console and launch it again using the user account in question

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Problem Cause

The account being used to launch the WEM Administration console was not added to the "Configured Administrator List" and thus did not have permissions to access the WEM Site.