Issues with public store microsoft dynamic application with per app VPN
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Article ID: CTX224885
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Updated On:
Description
, Able to launch the application successfully however after entering the url in the application it gives the error
"Your server is not available or doesn’t support this application"
Environment
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Resolution
Verify the vpn configuration from the article: https://www.citrix.com/blogs/2016/04/19/per-app-vpn-with-xenmobile-and-citrix-vpn/
Create a service on NS to verify if the Ns is able to reach the server .
General causes for the error message are as follows
○ Cause 1: The Dynamics 365 server is down. Verify that the server is on and connected to your network.
Sample Trace Message for Cause 1: “Dynamics CRM [Error] | Connection error: 404”
○ Cause 2: Your Dynamics 365 version is not supported. See https://technet.microsoft.com/en-us/library/dn531131.aspx for version support information.
○ Cause 3: This error can also occur if you enter an invalid URL. Make sure the same URL you have provided works to access Microsoft Dynamics 365 in your browser on your device.
Sample Trace Messages for Cause 4: “XMLHttpRequest: Network Error 0x2ee7, Could not complete the operation due to error 00002ee7.”
“Dynamics CRM [Error] | Connection error: 0”
○ Cause 4: If you connect to a Microsoft Dynamics 365 on-premises organization, this error can occur if the certificate from the Microsoft Dynamics 365 website is not trusted by the device. To avoid this scenario make sure to use a publicly trusted certificate. For more information, see Your server is not available or does not support this application.
Sample Trace Messages for
Cause 5: Windows 8: “XMLHttpRequest: Network Error 0x800c0019, Security certificate required to access this resource is invalid”
iPad: “[ERROR] Loading app failed due to SSL error”
Publishing the public certificate of the backend server to the device resolved the issue
Problem Cause
unable to trust the backend website
Issue/Introduction
Pushing Microsoft dynamic 365 as public store app with per app vpn in order to be able to access the internal server , however after entering the url in the application we get error message "Your server is not available or doesn’t support this application"
Additional Information
https://support.microsoft.com/en-us/help/2899983/while-configuring-dynamics-crm-for-phones-and-tablets,-you-receive-an-error-message.
https://technet.microsoft.com/en-us/library/dn531104.aspx
https://technet.microsoft.com/en-us/library/dn531131.aspx
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