WEM - Some Agents are not showing in WEM Console Agent List

WEM - Some Agents are not showing in WEM Console Agent List

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Article ID: CTX224831

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Updated On:

Description

Only one machine at a time within a particular group of WEM Agent machines is showing in the Agent list inside the WEM Administration Console.
***All machines in this group are receiving policies from WEM whether they appear in this list or not***
 

#1:  Upon first enumerating the Agent List from inside the WEM Administration Console, AM-W7X64-PVD-3 appears:
***Launch the WEM Administration Console, Click on "Administration" then "Agents"***

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#2:  Then, when hitting the Refresh button,  AM-W7X64-PVD-7 appears in the Agent List and AM-W7X64-PVD-3 disappears. 

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The same behavior is seen in the dbo.VUEMAgents table inside the WEM DB and the HardwareID value for any machine in this group that appears will be the same.
 
#1: When first loading the table from with SQL Server Management Studio, AM-W7X64-PVD-3 appears with the HardwareID of 420C8479B80C
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#2:  When refreshing the same Table, AM-W7X64-PVD-7 appears with the same HardwareID, 420C8479B80C

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Resolution

WEM Agents are uniquely identified by from the WEM Broker using the HardwareID which is the mac address of first connected interface of the computer/VM.
  1. Using hypervisor console, remove unused Network interface with duplicated MAC Address from each problematic machine.
  2. Run the "Ipconfig /all" command inside the CMD prompt on each machine to ensure the Network Interface with this MAC Address (HardwareID) is no longer attached/present
  3. Refresh the WEM Agent cache on these machines by right clicking on the WEM Agent Icon in the task bar and clicking "Refresh" and restart the WEM Agent Service to force it to check in again with the WEM Broker server.
  4. Review the dbo.VUEMAgents table inside the WEM Database and confirm that each WEM Agent is present and the hardwareID for each machine is unique and matches the MAC address for the remaining Network interface attached to each target device.

Problem Cause

Inside the WEM Database, within the dbo.VUEMAgents table, the HardwareID (MAC Address) for each machine in question was the same as all other machines in the problematic group.

WEM Agents are uniquely identified by by the WEM Broker using this HardwareId which is the Mac Address of first connected Network interface on any computer/VM where the WEM Agent is installed.

The WEM Broker was unable to distinguish between any 2 machines in this group since each machine had the same Network Interface with the identical MAC address attached as the first interface.